(+34) 673 566 782 - (+34) 960 653 052 formacion@imaginagroup.com

Listado de las principales funciones en Excel

¿Para qué sirve una función en Excel?

Una función en Excel sirve para utilizar una forma predefinida de automatizar algunos procesos y utilidades dentro de Excel. Aquí comentaremos algunos de los más útiles que podemos encontrar.

Para utilizar una función podemos utilizarla simplemente dentro de una celda, operar con ella en la celda o integrarla en otra función, siempre que el valor que devuelva sea el que necesita la función.

SUMA

Combinar celdas o columnas en una suma no es tan fácil como escribir el nombre de cada celda y añadir el símbolo + en medio.

La función más básica de Excel es SUMA. Se aplica usando la expresión:

SUMA(Valores, [Valores adicionales, ...])

Por ejemplo con un solo rango de valores:

=SUMA(A1:A5)

En este caso, sirve para sumar el intervalo de celdas de A1 a A5 incluyendo las que están en medio.

Imagen de ejemplo de la función Suma en Excel

Además podemos añadir más rangos de valores utilizando un punto y como para separarlos. Por ejemplo:

=SUMA(A1:A5;B1:B5)

Esta función sumará el intervalo  A1 a A5 y, además el, B1 a B5.

Imagen de ejemplo de la función Suma en Excel

Aunque la función se conoce como SUMA se puede combinar para sumar (+), restar (-), multiplicar (*) y dividir (/). Basta con usar el símbolo correspondiente. Ejemplo:

=SUMA(A1:A10)*10 suma el intervalo entre A1 y A10 y multiplica el resultado por 10.

SI

Esta función sirve para responder preguntas. Si el resultado corresponde con un valor concreto, obtendrás la respuesta que hayas configurado.

El ejemplo más sencillo es:

=SI(B2=1;"Sí";"No")

Si la celda B2 tiene el valor 1, la respuesta será “Sí”. En caso contrario, en la celda de la función veremos “No”.

Imagen de ejemplo de la función SI en Excel

Imagen de ejemplo de la función SI en Excel

La función SI nos permite obtener mensajes de alerta si, por ejemplo, nuestro presupuesto excede de cierta cantidad o nuestra cuenta acaba en números negativos. Para ello, podemos usar los símbolos mayor que y menor que.

=SI(B2>2000;"Gasto excesivo";"Gasto normal")

Imagen de ejemplo de la función SI en Excel

Imagen de ejemplo de la función SI en Excel

BUSCAR

La función BUSCAR se utiliza para buscar en una sola fila o columna y encontrar un valor desde la misma posición en una segunda fila o columna.

Esta función se aplica escribiendo en una celda

BUSCAR(valor_buscado; vector_de_comparación; [vector_resultado])

Donde valor_buscado es lo que estamos buscando a modo de referencia (número, texto, nombre de referencia…).

El vector de comparación se refiere a dónde tenemos que buscar (un intervalo de celdas, por ejemplo). En el [vector_resultado] está lo que buscamos realmente, porque lo desconocemos, a través del valor buscado.

Ejemplo:

=BUSCAR(7;A2:A10;B2:B10)

busca el valor 7 en las celdas comprendidas entre A2 y A10 y muestra el resultado que aparece en el intervalo B2 a B10.

Imagen de ejemplo de la función BUSCAR en Excel

BUSCARV

Si lo que queremos es buscar en una tabla entera, nos será más práctica la función BUSCARV.

La sintaxis es:

BUSCARV(Valor que buscamos; intervalo o rango en el que buscamos ese valor; el número de columna del rango o intervalo que contiene el valor devuelto; Coincidencia aproximada).

Siendo el tipo de coincidencia Verdadero o Falso o ara indicar si la conciencia puede ser aproximada o exacta. Por ejemplo:

=BUSCARV(5;B2:E11;3;FALSO)

D13 es la casilla del valor a buscar. En este caso se refiere al contenido de una celda. B2:E11 es un rango o intervalo donde se encuentra el valor que buscamos. 3 es el número de la columna donde se encuentra el valor que queremos obtener. FALSO se refiere a que queremos obtener un valor concreto.

Imagen de ejemplo de la función BUSCARV en Excel

COINCIDIR

Con COINCIDIR buscamos un elemento en un intervalo de celdas y obtendremos la posición de ese elemento en el rango que hemos indicado. Para esto utiliza la sintaxis:

COINCIDIR(valor_buscado,rango de celdas, [tipo_de_coincidencia])

Hay tres tipos de coincidencia: 1 muestra el valor mayor que es menor o igual que el valor buscado. 0 muestra el primer valor exactamente igual que el valor buscado. -1 muestra el valor menor que es mayor o igual que el valor buscado.

Por ejemplo:

=COINCIDIR(5;A1:A10;0)

Aquí 5 es el valor que buscamos dentro de una celda situada entre A1 y A10. Por último 0 se refiere a qué tipo de coincidencia buscamos, siendo el primer valor exactamente igual que el buscado.

Imagen de ejemplo de la función COINCIDIR en Excel

Ten en cuenta que el resultado mostrado por esta función es la posición del valor que buscamos en número absoluto. No lo confundas con el valor en sí que muestra dicha celda.

ELEGIR

Con la función ELEGIR obtendremos un valor de una lista de hasta 254 posibles y su sintaxis es:

ELEGIR(núm_índice; valor1; [valor2]; ...)

Usa el argumento núm_índice para devolver un valor de una lista de argumentos de valores. Use ELEGIR para seleccionar uno de los 254 valores posibles a partir del rango del argumento índice. Por ejemplo, si los valores son los días de la semana, ELEGIR devuelve uno de los días cuando se usa un número entre 1 y 7 como argumento núm_índice.

Por ejemplo:

=ELEGIR(2;A2;A3;A4;A5)

Aquí se mostrará el segundo valor del rango A2 a A5, es decir A3.

Imagen de ejemplo de la función ELEGIR en Excel

FECHA

Con esta función obtendremos una fecha a partir de tres valores diferentes. En concreto, año, mes y día, por ese orden.

=FECHA(año;mes;dia)

Imagen de ejemplo de la función FECHA en Excel

DIAS

La función DIAS sirve para mostrar el número de días transcurridos entre dos fechas distintas. Su sintaxis es:

DIAS(fecha final; fecha inicial)

Por ejemplo:

=DIAS("03/08/2003";"05/03/1997")

Esta función nos devolverá 2342 días de diferencia.

Imagen de ejemplo de la función DIAS en Excel

ENCONTRAR

Con esta función encontraremos una cadena de texto dentro de una segunda cadena. El resultado obtenido será la posición inicial de la primera cadena de texto. Utiliza la estructura:

ENCONTRAR(texto_buscado; dentro_del_texto; [núm_inicial]).

En texto buscado indicamos la expresión escrita que buscamos entrecomillada. En dentro del texto indicamos la celda donde se encuentra, por ejemplo A1. Opcionalmente, podemos indicar un número inicial para que la búsqueda empiece a partir de un carácter concreto.

Por ejemplo:

=ENCONTRAR("a";A2;4)

Devolvería la posición de la primera “a” en la celda A2, empezando por el cuarto carácter.

Imagen de ejemplo de la función ENCONTRAR en Excel

INDICE

Por último, INDICE nos da un valor o referencia de una celda o matriz de celdas desde una tabla o rango. Con la sintaxis:

INDICE(matriz; núm_fila; [núm_columna])

Indicamos la matriz donde buscar (un rango entre dos celdas de una o más columnas), el número de la fila donde buscar y, si hay varias columnas en la matriz, el número de la columna donde devolver un valor. El resultado será este último valor.

Por ejemplo:

=INDICE(A1:E5;2;4)

Nos devolverá el valor correspondiente a la segunda fila y segunda columna.

Imagen de ejemplo de la función INDICE en Excel

Uso de cookies: Este sitio web utiliza cookies para que usted tenga la mejor experiencia de usuario. Si continúa navegando está dando su consentimiento para la aceptación de las mencionadas cookies y la aceptación de nuestra política de cookies

ACEPTAR
Aviso de cookies